Checkout page unavailable
Incident Report for FutureLearn
Resolved
Checkout availability has now returned to normal. Thank you for your patience.
Posted Sep 16, 2020 - 18:03 UTC
Monitoring
Thank you for your patience.

The issue has been identified, and the checkout is now available for all learners. We're continuing to monitor the issue.
Posted Sep 16, 2020 - 17:12 UTC
Investigating
The checkout page is currently unavailable for some learners.

Our software engineers are aware of the problem and are currently investigating the issue. We hope to be back to normal soon.

Apologies for any inconvenience.
Posted Sep 16, 2020 - 16:37 UTC
This incident affected: www.futurelearn.com.