Database Performance Issues
Incident Report for FutureLearn
Resolved
Thank you for your patience. All systems are now working and the incident has been resolved.
Posted 3 months ago. Jul 23, 2019 - 08:59 UTC
Update
We've identified the issue and it should hopefully be working correctly now, but our software engineers are monitoring the situation.
Posted 3 months ago. Jul 22, 2019 - 16:31 UTC
Monitoring
Some long-running database maintenance was having a negative effect on the site's performance. Our software engineers are working on a fix now.
Posted 3 months ago. Jul 22, 2019 - 15:58 UTC
This incident affected: www.futurelearn.com.