Performance degraded across site
Incident Report for FutureLearn
Resolved
This incident has been resolved.
Posted Apr 02, 2020 - 12:24 UTC
Update
We have resolved the issue and performance is back to normal.
Posted Apr 02, 2020 - 12:11 UTC
Investigating
We are currently investigating performance issues across the site.
Posted Apr 02, 2020 - 12:05 UTC
This incident affected: www.futurelearn.com.