Page not found errors
Incident Report for FutureLearn
Resolved
UPDATE May 22, 20:00 BST

Our supplier has identified and fixed a problem with one of their servers in the Seattle area. Those who were affected by this issue should now be able to access the site as normal.

UPDATE 15:45 BST

We’re working with one our suppliers to resolve this issue. Please contact us at feedback@futurelearn.com if you’d like us to let you know when the issue has been resolved.

We apologise for the inconvenience and thank you for your patience.

11:21 BST

We’re aware that some learners in Canada are seeing ‘Page not found’ or ‘Page introuvable’ errors when visiting our site. If you are affected by this issue, please let us know at feedback@futurelearn.com and include your location and the name of your Internet Service Provider (ISP).
Posted about 1 year ago. May 21, 2018 - 10:21 UTC