FutureLearn site currently unavailable

Incident Report for FutureLearn

Resolved

This incident has been resolved.
Posted Dec 01, 2023 - 11:13 UTC

Investigating

Our apologies for the inconvenience, the FutureLearn site is currently unavailable. We are investigating it now and hope to have it back up very shortly.
Posted Dec 01, 2023 - 10:38 UTC
This incident affected: www.futurelearn.com.