Homepage not loading

Incident Report for FutureLearn

Resolved

This incident has been resolved.
Posted Jul 17, 2024 - 11:38 UTC

Investigating

The FutureLearn homepage is not loading. The rest of the website is working as expected. Please try https://www.futurelearn.com/sign-in to access the platform.
Posted Jul 17, 2024 - 11:21 UTC
This incident affected: www.futurelearn.com.