Degraded performance of FutureLearn site
Incident Report for FutureLearn
Resolved
The FutureLearn platform remains stable, we will continuing to monitor any further issues.
Posted Sep 30, 2022 - 08:10 UTC
Update
We are continuing to monitor for any further issues.
Posted Sep 29, 2022 - 09:23 UTC
Monitoring
Mitigations have been put in place to prevent the issue and we are monitoring site performance.
Posted Sep 29, 2022 - 09:20 UTC
Identified
The issue has been identified and we are working to resolve it as soon as possible.
Posted Sep 29, 2022 - 07:25 UTC
Investigating
We are currently experiencing some problems with FutureLearn and are investigating the cause. This may mean you find it difficult to sign in or the site may load slowly for you, or fail to load.

Our technical team are working on the problem right now and we hope to be back to normal soon.
Posted Sep 29, 2022 - 06:19 UTC
This incident affected: www.futurelearn.com.