Degraded performance of FutureLearn site
Incident Report for FutureLearn
Resolved
This incident has been resolved.
Posted Jul 16, 2024 - 08:30 UTC
Monitoring
We believe the issue is resolved and the site has been stable for a few hours, we will continue to the monitor the situation.
Posted Jul 15, 2024 - 16:33 UTC
Update
We are continuing to investigate this issue.
Posted Jul 15, 2024 - 14:00 UTC
Investigating
We are currently experiencing some problems with FutureLearn and are investigating the cause. This may mean you find it difficult to sign in or the site may load slowly for you, or fail to load.

Our technical team are working on the problem right now and we hope to be back to normal soon.
Posted Jul 15, 2024 - 13:57 UTC
This incident affected: www.futurelearn.com.