Performance Issues - Pages loading slowly or failing to load
Incident Report for FutureLearn
Resolved
Site performance has now returned to normal. Thank you for your patience.
Posted Oct 21, 2019 - 13:35 UTC
Identified
Some pages are intermittently failing to load, or are loading slowly. Our software engineers are working on a fix now.
Posted Oct 21, 2019 - 12:58 UTC
This incident affected: www.futurelearn.com.