Site loading slowly (may appear down for some users)
Incident Report for FutureLearn
Resolved
The issue has been resolved.
Posted Oct 12, 2020 - 13:26 UTC
Monitoring
A fix has been deployed and services have resumed. We are continuing to monitor the performance of the site.
Posted Oct 12, 2020 - 13:08 UTC
Investigating
We have identified an issue causing issues with the site and are working to put a resolution in place
Posted Oct 12, 2020 - 12:44 UTC
This incident affected: www.futurelearn.com.